Home l Brama Tool l Download l Our Demonstrations l Documentation l Links l Contact  


Downloading and Installing Brama

Prerequisites

Brama requires the presence of the Rodin platform in version 0.7.3 or higher. The installation of Brama requires the use of Eclipse’s “UpdateSite” function.  Three plugins are required:

  • Brama: the animation plugin itself
  • B2Rodin: a re-use of the importation wizard
  • GEF: the graphic library

Instructions

The installation of Brama requires the use of Eclipse’s “UpdateSite” feature.   Proceed as follows:

  • In the menu Help/Software Updates menu, enable“Find and Install”;

  • Select “Search for a new feature to install”;
  • Click on the "New Remote Site"button;
  • In the dialog box that appears, enter:
  • Click on the "New Remote Site"button;
  • In the dialog box that appears, enter:
  • Click on the "New Remote Site"button;
  • In the dialog box that appears, enter:

The following configuration should appear:

  • Click on the "Finish" button to browse the content of these update sites.
  • Select the most recent versions of Brama and b2rodin’s "features" (functions) (1.0.4 and 0.0.5 in this example).
  • Select Graphical Editing Framework.

  • Click on ′Finish′ twice. The downloading of the plugins will start immediately. Reboot the Eclipse platform to save these changes.
  • Online Help can assist you with setting up this tool. To access this help, select “Help” in the menu, then “Help Contents”.

The Help window appears. It is divided into two sections: the left section displays the help available and the right displays the relevant text once you have selected a chapter. Click on “Brama Help” to access help for Brama: